Adminer 4.8.1


14-05-2021 00:00 - Zdroj: php.vrana.cz
Adminer 4.8.1 opravuje XSS, které je ale naštěstí ve většině případů zastaveno díky Strict CSP ve všech moderních prohlížečích (CSP přidal Adminer 4.4.0). Ke skutečnému XSS dojde při použití ovladače PDO (který se použije, pokud nejsou k dispozici nativní ovladače) v Admineru 4.7.8 až 4.8.0 (kde bylo rozbité reportování chyb v PDO). (bug #797) Další změny: Potlačení dalších zbytečných varování v PHP 8. (bug #781) Již zmíněné nadměrné reportování chyb v PDO. (bug #786, rozbité od verze 4.7.8) MySQL: Možnost přesunu pohledů do jiné databáze a přejmenování databáze s pohledy. (bug #783) MariaDB: Sekvence se neberou jako pohledy. (PR #416) PostgreSQL: Podpora UPDATE OF triggerů. (bug #789) PostgreSQL: Podpora triggerů s více událostmi (OR). PostgreSQL: Oprava parsování cizích klíčů s ne-ASCII znaky v názvu sloupce. PostgreSQL < 10 PDO: Nezobrazovat všude GENERATED ALWAYS BY IDENTITY. (bug #785, rozbité od verze 4.7.9) SQLite: Oprava zobrazených typů. (bug #784, rozbité od verze 4.8.0) - Pokračovat...
addthis





Poslední příspěvky z blogu:
php.vrana.cz



Zašlete svůj blog
Požadavky na Blog
Ochrana osobních údajů
Kontakty

This site uses Thumbshots previews